Tests: Replace prove by autotools tap runner
[lttng-tools.git] / tests / unit / Makefile.am
index 7bfe65a8aaf0978851477c16cfb906605155f00c..b7f318fccc19f62093ad82ec7a8bf3144546eef2 100644 (file)
@@ -3,6 +3,16 @@ SUBDIRS = ini_config
 AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests/utils/ -I$(srcdir)
 AM_LDFLAGS =
 
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
+
+TESTS = test_kernel_data \
+       test_session \
+       test_uri \
+       test_utils_parse_size_suffix \
+       test_utils_expand_path \
+       ini_config/test_ini_config
+
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
 LIBS += -ldl
 endif
@@ -23,6 +33,7 @@ noinst_PROGRAMS += test_utils_parse_size_suffix test_utils_expand_path
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
+TESTS += test_ust_data
 endif
 
 # URI unit tests
This page took 0.022768 seconds and 4 git commands to generate.