Clean-up: sort noinst_PROGRAMS in test/unit/Makefile.am
[lttng-tools.git] / tests / unit / Makefile.am
index 8ce735890241c65574c4a14ed1cf75416951bcda..97b84b6cf6ee969b7460c91ee2092ad80c9ed924 100644 (file)
@@ -8,26 +8,28 @@ LOG_DRIVER_FLAGS='--merge'
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
        $(top_srcdir)/config/tap-driver.sh
 
-TESTS = test_kernel_data \
-       test_session \
-       test_uri \
-       test_utils_parse_size_suffix \
-       test_utils_parse_time_suffix \
-       test_utils_expand_path \
-       test_utils_compat_poll \
-       test_utils_compat_pthread \
-       test_string_utils \
-       test_notification \
-       test_event_rule \
-       test_directory_handle \
-       test_relayd_backward_compat_group_by_session \
+TESTS = \
        ini_config/test_ini_config \
-       test_fd_tracker \
-       test_uuid \
        test_buffer_view \
+       test_directory_handle \
+       test_event_expr_to_bytecode \
+       test_event_rule \
+       test_fd_tracker \
+       test_kernel_data \
+       test_kernel_probe \
+       test_notification \
        test_payload \
+       test_relayd_backward_compat_group_by_session \
+       test_session \
+       test_string_utils \
        test_unix_socket \
-       test_kernel_probe
+       test_uri \
+       test_utils_compat_poll \
+       test_utils_compat_pthread \
+       test_utils_expand_path \
+       test_utils_parse_size_suffix \
+       test_utils_parse_time_suffix \
+       test_uuid
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
@@ -40,18 +42,28 @@ LIBRELAYD=$(top_builddir)/src/common/relayd/librelayd.la
 LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 # Define test programs
-noinst_PROGRAMS = test_uri test_session test_kernel_data \
-                  test_utils_parse_size_suffix test_utils_parse_time_suffix \
-                  test_utils_expand_path test_utils_compat_poll test_utils_compat_pthread \
-                  test_string_utils test_notification test_directory_handle \
-                  test_relayd_backward_compat_group_by_session \
-                  test_fd_tracker test_uuid \
-                  test_buffer_view \
-                  test_payload \
-                  test_unix_socket \
-                  test_kernel_probe \
-                  test_condition \
-                  test_event_rule 
+noinst_PROGRAMS = \
+       test_buffer_view \
+       test_condition \
+       test_directory_handle \
+       test_event_expr_to_bytecode \
+       test_event_rule \
+       test_fd_tracker \
+       test_kernel_data \
+       test_kernel_probe \
+       test_notification \
+       test_payload \
+       test_relayd_backward_compat_group_by_session \
+       test_session \
+       test_string_utils \
+       test_unix_socket \
+       test_uri \
+       test_utils_compat_poll \
+       test_utils_compat_pthread \
+       test_utils_expand_path \
+       test_utils_parse_size_suffix \
+       test_utils_parse_time_suffix \
+       test_uuid
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
@@ -65,6 +77,7 @@ test_uri_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBHASHTABLE) $(DL_LIBS)
 # Sessiond objects
 SESSIOND_OBJS = $(top_builddir)/src/bin/lttng-sessiond/buffer-registry.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/cmd.$(OBJEXT) \
+        $(top_builddir)/src/bin/lttng-sessiond/condition-internal.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/save.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/notification-thread-commands.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/shm.$(OBJEXT) \
@@ -237,3 +250,7 @@ test_unix_socket_LDADD = $(LIBTAP) $(LIBSESSIOND_COMM) $(LIBCOMMON)
 # Kernel probe location api test
 test_kernel_probe_SOURCES = test_kernel_probe.c
 test_kernel_probe_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
+#
+# Event expression to bytecode test
+test_event_expr_to_bytecode_SOURCES = test_event_expr_to_bytecode.c
+test_event_expr_to_bytecode_LDADD = $(LIBTAP) $(LIBLTTNG_CTL) $(LIBCOMMON)
This page took 0.023893 seconds and 4 git commands to generate.