port: Add pthread_setname_np FreeBSD compat
[lttng-tools.git] / tests / unit / Makefile.am
index a91b4dbd92682f01ccb5a891d21222a5de080001..8e2703726e9d8e64bf88e9c8377abb25314585dd 100644 (file)
@@ -15,6 +15,7 @@ TESTS = test_kernel_data \
        test_utils_parse_time_suffix \
        test_utils_expand_path \
        test_utils_compat_poll \
+       test_utils_compat_pthread \
        test_string_utils \
        test_notification \
        test_event_rule \
@@ -41,7 +42,7 @@ LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 # Define test programs
 noinst_PROGRAMS = test_uri test_session test_kernel_data \
                   test_utils_parse_size_suffix test_utils_parse_time_suffix \
-                  test_utils_expand_path test_utils_compat_poll \
+                  test_utils_expand_path test_utils_compat_poll test_utils_compat_pthread \
                   test_string_utils test_notification test_directory_handle \
                   test_relayd_backward_compat_group_by_session \
                   test_fd_tracker test_uuid \
@@ -178,6 +179,11 @@ test_utils_compat_poll_SOURCES = test_utils_compat_poll.c
 test_utils_compat_poll_LDADD  = $(LIBTAP) $(LIBHASHTABLE) $(DL_LIBS) \
                      $(top_builddir)/src/common/compat/libcompat.la $(LIBCOMMON)
 
+# compat_pthread unit test
+test_utils_compat_pthread_SOURCES = test_utils_compat_pthread.c
+test_utils_compat_pthread_LDADD  = $(LIBTAP) \
+                     $(top_builddir)/src/common/compat/libcompat.la $(LIBCOMMON)
+
 # expand_path unit test
 test_utils_expand_path_SOURCES = test_utils_expand_path.c
 test_utils_expand_path_LDADD = $(LIBTAP) $(LIBHASHTABLE) $(LIBCOMMON) $(DL_LIBS)
This page took 0.02319 seconds and 4 git commands to generate.