Cleanup: Move `create_posix_shm()` to common/shm.c
[lttng-tools.git] / tests / unit / Makefile.am
index 01b2981524bdebb271c9a867d03946c087e85b06..01e7e82c0fbed2cee4cdcf4e38e6d103ba7a17e4 100644 (file)
@@ -8,27 +8,29 @@ LOG_DRIVER_FLAGS='--merge'
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
        $(top_srcdir)/config/tap-driver.sh
 
-TESTS = test_kernel_data \
-       test_session \
-       test_uri \
-       test_utils_parse_size_suffix \
-       test_utils_parse_time_suffix \
-       test_utils_expand_path \
-       test_utils_compat_poll \
-       test_utils_compat_pthread \
-       test_string_utils \
-       test_notification \
-       test_event_rule \
-       test_directory_handle \
-       test_relayd_backward_compat_group_by_session \
+TESTS = \
        ini_config/test_ini_config \
-       test_fd_tracker \
-       test_uuid \
        test_buffer_view \
+       test_directory_handle \
        test_event_expr_to_bytecode \
+       test_event_rule \
+       test_fd_tracker \
+       test_kernel_data \
+       test_kernel_probe \
+       test_log_level_rule \
+       test_notification \
        test_payload \
+       test_relayd_backward_compat_group_by_session \
+       test_session \
+       test_string_utils \
        test_unix_socket \
-       test_kernel_probe
+       test_uri \
+       test_utils_compat_poll \
+       test_utils_compat_pthread \
+       test_utils_expand_path \
+       test_utils_parse_size_suffix \
+       test_utils_parse_time_suffix \
+       test_uuid
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
@@ -41,19 +43,29 @@ LIBRELAYD=$(top_builddir)/src/common/relayd/librelayd.la
 LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 # Define test programs
-noinst_PROGRAMS = test_uri test_session test_kernel_data \
-                  test_utils_parse_size_suffix test_utils_parse_time_suffix \
-                  test_utils_expand_path test_utils_compat_poll test_utils_compat_pthread \
-                  test_string_utils test_notification test_directory_handle \
-                  test_relayd_backward_compat_group_by_session \
-                  test_fd_tracker test_uuid \
-                  test_buffer_view \
-                  test_payload \
-                  test_unix_socket \
-                  test_kernel_probe \
-                  test_condition \
-                 test_event_expr_to_bytecode \
-                  test_event_rule 
+noinst_PROGRAMS = \
+       test_buffer_view \
+       test_condition \
+       test_directory_handle \
+       test_event_expr_to_bytecode \
+       test_event_rule \
+       test_fd_tracker \
+       test_kernel_data \
+       test_kernel_probe \
+       test_log_level_rule \
+       test_notification \
+       test_payload \
+       test_relayd_backward_compat_group_by_session \
+       test_session \
+       test_string_utils \
+       test_unix_socket \
+       test_uri \
+       test_utils_compat_poll \
+       test_utils_compat_pthread \
+       test_utils_expand_path \
+       test_utils_parse_size_suffix \
+       test_utils_parse_time_suffix \
+       test_uuid
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
@@ -70,7 +82,6 @@ SESSIOND_OBJS = $(top_builddir)/src/bin/lttng-sessiond/buffer-registry.$(OBJEXT)
         $(top_builddir)/src/bin/lttng-sessiond/condition-internal.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/save.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/notification-thread-commands.$(OBJEXT) \
-        $(top_builddir)/src/bin/lttng-sessiond/shm.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/kernel.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/ht-cleanup.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/notification-thread.$(OBJEXT) \
@@ -203,10 +214,11 @@ test_string_utils_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBSTRINGUTILS) $(DL_LIBS)
 # Notification api
 test_notification_SOURCES = test_notification.c
 test_notification_LDADD = $(LIBTAP) $(LIBLTTNG_CTL) $(DL_LIBS)
-#
+
 # Event rule api
 test_event_rule_SOURCES = test_event_rule.c
-test_event_rule_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
+test_event_rule_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS) \
+                     $(top_builddir)/src/bin/lttng/lttng-loglevel.$(OBJEXT)
 
 # Condition api
 test_condition_SOURCES = test_condition.c
@@ -244,3 +256,7 @@ test_kernel_probe_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
 # Event expression to bytecode test
 test_event_expr_to_bytecode_SOURCES = test_event_expr_to_bytecode.c
 test_event_expr_to_bytecode_LDADD = $(LIBTAP) $(LIBLTTNG_CTL) $(LIBCOMMON)
+
+# Log level rule api
+test_log_level_rule_SOURCES = test_log_level_rule.c
+test_log_level_rule_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
This page took 0.025601 seconds and 4 git commands to generate.