Fix: Don't override user variables within the build system
[lttng-tools.git] / tests / regression / ust / linking / Makefile.am
index 1c80ae8392144f0448ba0c228c3815e509df6d65..c70bc53a2eccaed40aebc4d5b87b19cc269dc247 100644 (file)
@@ -1,6 +1,6 @@
 # -Wsystem-headers is needed to print warnings in the tracepoint
 # description file.
-AM_CPPFLAGS = -I$(srcdir) -I$(top_builddir)/include -Wsystem-headers
+AM_CPPFLAGS += -I$(srcdir) -Wsystem-headers
 
 # Set LIBS to nothing so the application does not link on useless
 # libraries.
@@ -10,7 +10,7 @@ LIBS =
 demo_builtin_SOURCES = demo.c tp.c tp2.c tp3.c ust_tests_demo.h \
        ust_tests_demo2.h ust_tests_demo3.h
 demo_builtin_LDADD = -llttng-ust
-demo_builtin_CFLAGS = -Werror=old-style-definition
+demo_builtin_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
 
 # Build a version statically linked to the providers
 # contains ust_tests_demo.h and ust_tests_demo2.h provider probes
@@ -79,7 +79,7 @@ liblttng_ust_provider_ust_tests_demo3_la_LDFLAGS = \
 
 noinst_PROGRAMS += demo
 demo_SOURCES = demo.c ust_tests_demo.h
-demo_CFLAGS = -DTEST_DYNAMIC_LINKAGE
+demo_CFLAGS = -DTEST_DYNAMIC_LINKAGE $(AM_CFLAGS)
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
 demo_LDADD = -ldl
This page took 0.023196 seconds and 4 git commands to generate.