Fix: test: log4j: missing static test files for dist and out of tree build
[lttng-tools.git] / tests / regression / ust / java-log4j / Makefile.am
index 7035ecf929feaad9da4d51d61ddbe21ca6c91ae2..7d6c0481a0997629587a9183299560b5b32972e7 100644 (file)
@@ -1,4 +1,3 @@
-if BUILD_JAVA_LOG4J_AGENT
 
 noinst_SCRIPTS = test_java_log4j JTestLTTng.java
 EXTRA_DIST = test_java_log4j JTestLTTng.java
@@ -9,14 +8,19 @@ else
 JCC=javac
 endif
 
-all-local: JTestLTTng.class
+# We still need to copy static files for out of tree and dist build
+if BUILD_JAVA_LOG4J_AGENT
+all-local: static_file JTestLTTng.class
 
 %.class: %.java
        $(JCC) -d "$(builddir)" $(JAVACFLAGS) $<
+else
+all-local: static_file
+endif # BUILD_JAVA_LOG4J_AGENT
 
 JTestLTTng.class: JTestLTTng.java
 
-all-local:
+static_file:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
                        cp -f $(srcdir)/$$script $(builddir); \
@@ -31,4 +35,3 @@ clean-local:
                done; \
        fi
 
-endif # BUILD_JAVA_LOG4J_AGENT
This page took 0.023122 seconds and 4 git commands to generate.