Tests: Java agent: update after Java agent refactoring
[lttng-tools.git] / tests / regression / ust / java-jul / Makefile.am
index 4446c524fb72311d83068ac3d4bbc06f8da6eb82..877237fffd02d47d37c65630f18b226e34a51836 100644 (file)
@@ -1,24 +1,15 @@
-if BUILD_JAVA_AGENT
+JAVAROOT = .
 
 noinst_SCRIPTS = test_java_jul JTestLTTng.java
 EXTRA_DIST = test_java_jul JTestLTTng.java
 
-if HAVE_JAVA_JDK
-JCC=$(JAVA_JDK)/bin/javac
-else
-JCC=javac
-endif
+if BUILD_JAVA_JUL_AGENT
+dist_noinst_JAVA = JTestLTTng.java
+endif # BUILD_JAVA_JUL_AGENT
 
-AGENT_JAR_FILE=$(java_agent_jar_path)
+all-local: static_file
 
-all-local: JTestLTTng.class
-
-%.class: %.java
-       $(JCC) -d "$(builddir)" -cp "$(AGENT_JAR_FILE):." $<
-
-JTestLTTng.class: JTestLTTng.java
-
-all-local:
+static_file:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
                        cp -f $(srcdir)/$$script $(builddir); \
@@ -33,4 +24,3 @@ clean-local:
                done; \
        fi
 
-endif # BUILD_JAVA_AGENT
This page took 0.022892 seconds and 4 git commands to generate.