Refactor: test: wrapper for destroy_lttng_session
[lttng-tools.git] / tests / regression / ust / java-jul / Makefile.am
index 302d2efda36f5681da29b5e200435354eff70d6a..286e3df2293611f2888cbd8603529de6c5eea937 100644 (file)
@@ -1,4 +1,3 @@
-if BUILD_JAVA_JUL
 
 noinst_SCRIPTS = test_java_jul JTestLTTng.java
 EXTRA_DIST = test_java_jul JTestLTTng.java
@@ -9,22 +8,27 @@ else
 JCC=javac
 endif
 
-JUL_JAR_FILE=$(java_jul_jar_path)
+AGENT_JAR_FILE=$(java_agent_jar_path)
 
-all-local: JTestLTTng.class
 
+# Still need to copy test files in case of out of tree build
+if BUILD_JAVA_AGENT
+all-local: static_file JTestLTTng.class
 %.class: %.java
-       $(JCC) -d "$(builddir)" -cp "$(JUL_JAR_FILE):." $<
+       $(JCC) -d "$(builddir)" -cp "$(AGENT_JAR_FILE):." $<
+else
+all-local: static_file
+endif # BUILD_JAVA_AGENT
 
-JTestLTTng.class: JTestLTTng.java
 
-all-local:
+static_file:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
                        cp -f $(srcdir)/$$script $(builddir); \
                done; \
        fi
 
+
 clean-local:
        rm -f *.class
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
@@ -33,4 +37,3 @@ clean-local:
                done; \
        fi
 
-endif # BUILD_JAVA_JUL
This page took 0.024041 seconds and 4 git commands to generate.