Fix: tests: don't build dynamic lib tests if support disabled
[lttng-tools.git] / tests / regression / ust / clock-override / Makefile.am
index 95065e0ed1ba6b580395be72521dcd1f3f021c2f..cc4b02c1eba69223f9f2f8839bfc7ea8abfe819a 100644 (file)
@@ -1,3 +1,14 @@
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+
+CLEANFILES = lttng-ust-clock-override-test.so \
+       lttng-ust-clock-override-test.so.debug
+
+EXTRA_DIST = test_clock_override lttng-ust-clock-override-test.c
+
+else
+
 AM_CPPFLAGS = -I$(srcdir)
 
 # The rpath is necessary because libtool won't build a shared library
@@ -35,3 +46,5 @@ clean-local:
                        rm -f $(builddir)/$$script; \
                done; \
        fi
+
+endif
This page took 0.023231 seconds and 4 git commands to generate.