.gitignore: ignore local vscode workspace settings file
[lttng-tools.git] / tests / regression / ust / baddr-statedump / Makefile.am
index 35de5f9416a3b2eceb9c42251f1a9c5088fd9e74..d37dbb6dd5751f5f0264a165440264b9718e8eb5 100644 (file)
@@ -6,6 +6,10 @@ objcopy_verbose_0 = @echo OBJCOPY $@;
 
 AM_CPPFLAGS += -I$(srcdir) -g
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_PROGRAMS = prog
 prog_SOURCES = prog.c tp.c tp.h
 prog_LDADD = $(UST_LIBS) $(DL_LIBS)
@@ -15,11 +19,11 @@ EXTRA_DIST = test_baddr-statedump test_baddr-statedump.py
 
 # Extract debug symbols
 prog.debug: prog
-       $(objcopy_verbose)$(OBJCOPY) --only-keep-debug prog prog.debug
+       $(objcopy_verbose)$(LIBTOOL) --mode=execute $(OBJCOPY) --only-keep-debug prog prog.debug
 
 # Strip and add debuglink
 prog.strip: prog.debug
-       @cp -f prog prog.strip
+       @$(LIBTOOL) --mode=execute cp -f prog prog.strip
        $(objcopy_verbose)$(OBJCOPY) --strip-debug --add-gnu-debuglink=prog.debug prog.strip
 
 all-local: prog.strip
This page took 0.024208 seconds and 4 git commands to generate.