Tests: Ust getcpu override plugin
[lttng-tools.git] / tests / regression / ust / Makefile.am
index a11a65946510853a160da722c40b6f0c73bde116..e3a04c009b5f0e141064c14d032e0fd67660f6cc 100644 (file)
@@ -1,24 +1,23 @@
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
-                 overlap
+               overlap buffers-pid linking daemon exit-fast fork libc-wrapper \
+               periodical-metadata-flush java-jul java-log4j python-logging \
+               getcpu-override
 
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils -I$(top_srcdir)/src -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
+EXTRA_DIST = test_event_basic test_event_wildcard test_event_tracef test_event_perf
 
-EXTRA_DIST = runall.sh run-ust-global-tests.sh test_event_basic
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-noinst_PROGRAMS = ust_global_event_wildcard
-
-UTILS=$(top_srcdir)/tests/utils/utils.h
-LIBLTTNG=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
-
-SESSIONDSRC=$(top_srcdir)/src/common/sessiond-comm/sessiond-comm.c \
-                $(top_srcdir)/src/common/sessiond-comm/unix.c \
-                $(top_srcdir)/src/common/sessiond-comm/inet.c \
-                $(top_srcdir)/src/common/sessiond-comm/inet6.c
-
-ust_global_event_wildcard_SOURCES = ust_global_event_wildcard.c $(UTILS) \
-               $(SESSIONDSRC)
-ust_global_event_wildcard_LDADD = $(LIBLTTNG)
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 endif
This page took 0.023191 seconds and 4 git commands to generate.