Tests: add regression test for Java JUL support
[lttng-tools.git] / tests / regression / ust / Makefile.am
index d8904bb78c0227e7186aec989d5aea3cc07d38ef..a4e3455aec145744f1301732be1135fb9fcd082d 100644 (file)
@@ -1,7 +1,22 @@
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
-                 overlap
+               overlap buffers-pid linking daemon exit-fast fork libc-wrapper \
+               periodical-metadata-flush java-jul
 
-EXTRA_DIST = runall.sh run-ust-global-tests.sh test_event_basic test_event_wildcard
+EXTRA_DIST = test_event_basic test_event_wildcard
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 endif
This page took 0.022601 seconds and 4 git commands to generate.