Tests: add duplicated providers tests
[lttng-tools.git] / tests / regression / ust / Makefile.am
index a11a65946510853a160da722c40b6f0c73bde116..6237b1610653c12b90f957817fd7e2d1bfc5979e 100644 (file)
@@ -1,24 +1,28 @@
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
-                 overlap
+               overlap buffers-pid linking daemon exit-fast fork libc-wrapper \
+               periodical-metadata-flush java-jul java-log4j python-logging \
+               getcpu-override clock-override type-declarations \
+               rotation-destroy-flush blocking multi-lib
 
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils -I$(top_srcdir)/src -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
-
-EXTRA_DIST = runall.sh run-ust-global-tests.sh test_event_basic
-
-noinst_PROGRAMS = ust_global_event_wildcard
+if HAVE_OBJCOPY
+SUBDIRS += baddr-statedump ust-dl
+endif
 
-UTILS=$(top_srcdir)/tests/utils/utils.h
-LIBLTTNG=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
+EXTRA_DIST = test_event_basic test_event_tracef test_event_perf
 
-SESSIONDSRC=$(top_srcdir)/src/common/sessiond-comm/sessiond-comm.c \
-                $(top_srcdir)/src/common/sessiond-comm/unix.c \
-                $(top_srcdir)/src/common/sessiond-comm/inet.c \
-                $(top_srcdir)/src/common/sessiond-comm/inet6.c
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-ust_global_event_wildcard_SOURCES = ust_global_event_wildcard.c $(UTILS) \
-               $(SESSIONDSRC)
-ust_global_event_wildcard_LDADD = $(LIBLTTNG)
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 endif
This page took 0.02291 seconds and 4 git commands to generate.