fix: relayd: unaligned access in trace_chunk_registry_ht_key_hash
[lttng-tools.git] / tests / regression / ust / Makefile.am
index a11a65946510853a160da722c40b6f0c73bde116..dd8186f9a652953aa62fbf88a25a1b4ca56583cf 100644 (file)
@@ -1,24 +1,55 @@
-if HAVE_LIBLTTNG_UST_CTL
-SUBDIRS = nprocesses high-throughput low-throughput before-after multi-session \
-                 overlap
-
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils -I$(top_srcdir)/src -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
+# SPDX-License-Identifier: GPL-2.0-only
 
-EXTRA_DIST = runall.sh run-ust-global-tests.sh test_event_basic
+if HAVE_LIBLTTNG_UST_CTL
+SUBDIRS = \
+       before-after \
+       blocking \
+       buffers-pid \
+       clock-override \
+       daemon \
+       exit-fast \
+       fork \
+       getcpu-override \
+       high-throughput \
+       java-jul \
+       java-log4j \
+       java-log4j2 \
+       libc-wrapper \
+       linking \
+       low-throughput \
+       multi-lib \
+       multi-session \
+       namespaces \
+       nprocesses \
+       overlap \
+       periodical-metadata-flush \
+       rotation-destroy-flush \
+       type-declarations \
+       ust-constructor
 
-noinst_PROGRAMS = ust_global_event_wildcard
+if HAVE_OBJCOPY
+SUBDIRS += \
+       baddr-statedump \
+       ust-dl
+endif
 
-UTILS=$(top_srcdir)/tests/utils/utils.h
-LIBLTTNG=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
+EXTRA_DIST = \
+       test_event_basic \
+       test_event_perf \
+       test_event_tracef
 
-SESSIONDSRC=$(top_srcdir)/src/common/sessiond-comm/sessiond-comm.c \
-                $(top_srcdir)/src/common/sessiond-comm/unix.c \
-                $(top_srcdir)/src/common/sessiond-comm/inet.c \
-                $(top_srcdir)/src/common/sessiond-comm/inet6.c
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-ust_global_event_wildcard_SOURCES = ust_global_event_wildcard.c $(UTILS) \
-               $(SESSIONDSRC)
-ust_global_event_wildcard_LDADD = $(LIBLTTNG)
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 endif
This page took 0.024451 seconds and 4 git commands to generate.