Fix: support VPATH build for tests
[lttng-tools.git] / tests / regression / tools / snapshots / Makefile.am
index 40cb8e1102b4e6ae14ec1af172c6a2ab642ba78e..66e9ddd318039c50be580a7bc9f61e0e1defe0b8 100644 (file)
@@ -1,2 +1,16 @@
 noinst_SCRIPTS = test_kernel test_kernel_streaming test_ust test_ust_streaming
 EXTRA_DIST = test_kernel test_kernel_streaming test_ust test_ust_streaming
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023571 seconds and 4 git commands to generate.