Test: session rotation schedule API
[lttng-tools.git] / tests / regression / tools / rotation / Makefile.am
index 2fbb54e046386e626e9cca966c59a418c7d416ab..c063a8036970fd0ebc23092215ce0306195127a3 100644 (file)
@@ -1,5 +1,14 @@
-noinst_SCRIPTS = test_kernel test_ust test_save_load_mi rotate_utils.sh
-EXTRA_DIST = test_kernel test_ust test_save_load_mi rotate_utils.sh
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils/ -I$(srcdir)
+
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
+LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
+
+noinst_PROGRAMS = schedule_api
+schedule_api_SOURCES = schedule_api.c
+schedule_api_LDADD = $(LIBTAP) $(LIBLTTNG_CTL)
+
+noinst_SCRIPTS = test_kernel test_ust test_save_load_mi test_schedule_api rotate_utils.sh
+EXTRA_DIST = test_kernel test_ust test_save_load_mi test_schedule_api rotate_utils.sh
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.022818 seconds and 4 git commands to generate.