tests: append to AM_CFLAGS instead of overriding it
[lttng-tools.git] / tests / regression / tools / notification / Makefile.am
index 707047c3a3ce9154dc6888d71e9e2b4db76bc3b6..bc2c9123c2882e2d8c5b5fef32e0082bdaaf777b 100644 (file)
@@ -1,16 +1,16 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests -I$(top_srcdir)/tests/utils/ -I$(srcdir)
-AM_LDFLAGS =
+# SPDX-License-Identifier: GPL-2.0-only
 
+AM_CFLAGS += -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 LIB_LTTNG_CTL = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
-noinst_PROGRAMS = base_client notification
+noinst_PROGRAMS = base_client notification rotation
 
 if NO_SHARED
 
 CLEANFILES = libpause_consumer.so libpause_consumer.so.debug
-EXTRA_DIST = test_notification test_notification_multi_app base_client.c notification.c consumer_testpoints.c
+EXTRA_DIST = test_notification_ust test_notification_kernel test_notification_multi_app base_client.c notification.c consumer_testpoints.c
 
 else
 
@@ -20,7 +20,10 @@ FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
                           -rpath $(abs_builddir)
 
 libpause_consumer_la_SOURCES = consumer_testpoints.c
-libpause_consumer_la_LIBADD = $(top_builddir)/src/common/libcommon.la $(DL_LIBS)
+libpause_consumer_la_LIBADD = \
+       $(top_builddir)/src/common/libcommon.la \
+       $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
+       $(DL_LIBS)
 libpause_consumer_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
 noinst_LTLIBRARIES = libpause_consumer.la
 
@@ -30,8 +33,11 @@ base_client_LDADD = $(LIB_LTTNG_CTL)
 notification_SOURCES = notification.c
 notification_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
 
-noinst_SCRIPTS = test_notification test_notification_multi_app
-EXTRA_DIST = test_notification test_notification_multi_app
+rotation_SOURCES = rotation.c
+rotation_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
+
+noinst_SCRIPTS = test_notification_ust test_notification_kernel test_notification_multi_app test_rotation
+EXTRA_DIST = test_notification_ust test_notification_kernel test_notification_multi_app test_rotation
 
 
 all-local:
This page took 0.026487 seconds and 4 git commands to generate.