Tests: notification: Makefile.am formatting
[lttng-tools.git] / tests / regression / tools / notification / Makefile.am
index 0e7a667014db48a9f7168217a10879be838152e3..3aca442f2235db9adb9f90f4e46e0aa4048eeba3 100644 (file)
@@ -1,6 +1,6 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests -I$(top_srcdir)/tests/utils/ -I$(srcdir)
-AM_LDFLAGS =
+# SPDX-License-Identifier: GPL-2.0-only
 
+AM_CFLAGS += -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 LIB_LTTNG_CTL = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
@@ -10,8 +10,20 @@ noinst_PROGRAMS = base_client notification rotation
 if NO_SHARED
 
 CLEANFILES = libpause_consumer.so libpause_consumer.so.debug
-EXTRA_DIST = test_notification_ust test_notification_kernel test_notification_multi_app base_client.c notification.c consumer_testpoints.c
-
+EXTRA_DIST = \
+            base_client.c \
+            consumer_testpoints.c \
+            notification.c \
+            test_notification_kernel_buffer_usage \
+            test_notification_kernel_error \
+            test_notification_kernel_instrumentation \
+            test_notification_kernel_syscall \
+            test_notification_kernel_userspace_probe \
+            test_notification_multi_app \
+            test_notification_ust_buffer_usage \
+            test_notification_ust_error \
+            test_notification_ust_event_rule_condition_exclusion \
+            util_event_generator.sh
 else
 
 # In order to test the health check feature, the helper library
@@ -21,6 +33,7 @@ FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
 
 libpause_consumer_la_SOURCES = consumer_testpoints.c
 libpause_consumer_la_LIBADD = \
+       $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
        $(top_builddir)/src/common/libcommon.la \
        $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
        $(DL_LIBS)
@@ -36,9 +49,31 @@ notification_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
 rotation_SOURCES = rotation.c
 rotation_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
 
-noinst_SCRIPTS = test_notification_ust test_notification_kernel test_notification_multi_app test_rotation
-EXTRA_DIST = test_notification_ust test_notification_kernel test_notification_multi_app test_rotation
+noinst_SCRIPTS = \
+       test_notification_kernel_buffer_usage \
+       test_notification_kernel_error \
+       test_notification_kernel_instrumentation \
+       test_notification_kernel_syscall \
+       test_notification_kernel_userspace_probe \
+       test_notification_multi_app \
+       test_notification_ust_buffer_usage \
+       test_notification_ust_error \
+       test_notification_ust_event_rule_condition_exclusion \
+       test_rotation \
+       util_event_generator.sh
 
+EXTRA_DIST = \
+       test_notification_kernel_buffer_usage \
+       test_notification_kernel_error \
+       test_notification_kernel_instrumentation \
+       test_notification_kernel_syscall \
+       test_notification_kernel_userspace_probe \
+       test_notification_multi_app \
+       test_notification_ust_buffer_usage \
+       test_notification_ust_error \
+       test_notification_ust_event_rule_condition_exclusion \
+       test_rotation \
+       util_event_generator.sh
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.0238 seconds and 4 git commands to generate.