Fix: use LIBS instead of AM_LDFLAGS for dl and c linking
[lttng-tools.git] / tests / regression / tools / health / Makefile.am
index 098fbf421aee5ee9c119b0fc14ecf66cc7ecd6d0..643dd31d2081b3deaba926d78575d26e3ee5770c 100644 (file)
@@ -2,10 +2,10 @@ AM_CFLAGS = -I. -O2 -g -I$(top_srcdir)/include
 AM_LDFLAGS =
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 if NO_SHARED
@@ -37,5 +37,21 @@ health_check_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                     $(top_builddir)/src/common/libcommon.la
 endif
 
-dist_noinst_SCRIPTS = test_thread_exit test_thread_stall test_tp_fail
-EXTRA_DIST = test_thread_exit test_thread_stall test_tp_fail
+dist_noinst_SCRIPTS = test_thread_exit test_thread_stall test_tp_fail \
+               test_health.sh test_thread_ok
+EXTRA_DIST = test_thread_exit test_thread_stall test_tp_fail \
+               test_health.sh test_thread_ok
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023464 seconds and 4 git commands to generate.