Fix: force the use of our _FORTIFY_SOURCE definition
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index 3ab6d75bde10c0704e96e4f27e2b892c9e89da9c..8547efd675b937e72ba5509b3d7bb89ee26266d8 100644 (file)
@@ -1,13 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 EXTRA_DIST = test_event_basic test_all_events test_syscall \
                test_clock_override test_rotation_destroy_flush \
                test_select_poll_epoll test_lttng_logger \
                test_userspace_probe test_callstack \
-               test_syscall validate_select_poll_epoll.py
+               test_syscall validate_select_poll_epoll.py \
+               test_ns_contexts test_ns_contexts_change
 
 noinst_PROGRAMS = select_poll_epoll
 select_poll_epoll_SOURCES = select_poll_epoll.c
 select_poll_epoll_LDADD = $(POPT_LIBS)
-select_poll_epoll_CFLAGS = $(POPT_CFLAGS) -fno-stack-protector -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
+select_poll_epoll_CFLAGS = $(POPT_CFLAGS) -fno-stack-protector -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0 $(AM_CFLAGS)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023093 seconds and 4 git commands to generate.