lttng: Add list-triggers command
[lttng-tools.git] / tests / regression / Makefile.am
index 1d24a79663bf6d89d47b9a876fd77a3a5e82b3c9..cc554195667519125af0f902f19af83061f56e55 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS = tools kernel ust
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
@@ -37,7 +39,9 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/notification/test_notification_multi_app \
        tools/clear/test_ust \
        tools/clear/test_kernel \
-       tools/tracker/test_event_tracker
+       tools/tracker/test_event_tracker \
+       tools/trigger/test_add_trigger_cli \
+       tools/trigger/test_list_triggers_cli
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -57,10 +61,14 @@ TESTS += ust/before-after/test_before_after \
        ust/blocking/test_blocking \
        ust/multi-lib/test_multi_lib \
        ust/rotation-destroy-flush/test_rotation_destroy_flush \
-       ust/namespaces/test_ns_contexts \
-       ust/namespaces/test_ns_contexts_change \
        tools/metadata/test_ust \
        tools/relayd-grouping/test_ust
+
+if IS_LINUX
+TESTS += \
+       ust/namespaces/test_ns_contexts \
+       ust/namespaces/test_ns_contexts_change
+endif # IS_LINUX
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.022984 seconds and 4 git commands to generate.