lttng: Add list-triggers command
[lttng-tools.git] / tests / regression / Makefile.am
index 0f547a64d28a5e91cfbc4ae90090e6f201fd5e60..cc554195667519125af0f902f19af83061f56e55 100644 (file)
@@ -1,7 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS = tools kernel ust
 
-LOG_DRIVER_FLAGS='--merge'
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
+LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
        $(top_srcdir)/config/tap-driver.sh
 
 TESTS = tools/filtering/test_invalid_filter \
@@ -19,6 +21,7 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/snapshots/test_ust_streaming \
        tools/save-load/test_save \
        tools/save-load/test_load \
+       tools/save-load/test_autoload \
        tools/mi/test_mi \
        tools/wildcard/test_event_wildcard \
        tools/crash/test_crash \
@@ -26,7 +29,19 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/regen-statedump/test_ust \
        tools/notification/test_notification_ust \
        tools/notification/test_notification_kernel \
-       tools/notification/test_notification_multi_app
+       tools/notification/test_notification_multi_app \
+       tools/rotation/test_ust \
+       tools/rotation/test_kernel \
+       tools/rotation/test_save_load_mi \
+       tools/rotation/test_schedule_api \
+       tools/metadata/test_kernel \
+       tools/working-directory/test_relayd_working_directory \
+       tools/notification/test_notification_multi_app \
+       tools/clear/test_ust \
+       tools/clear/test_kernel \
+       tools/tracker/test_event_tracker \
+       tools/trigger/test_add_trigger_cli \
+       tools/trigger/test_list_triggers_cli
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -43,7 +58,17 @@ TESTS += ust/before-after/test_before_after \
        ust/test_event_basic \
        ust/test_event_tracef \
        ust/test_event_perf \
-       ust/blocking/test_blocking
+       ust/blocking/test_blocking \
+       ust/multi-lib/test_multi_lib \
+       ust/rotation-destroy-flush/test_rotation_destroy_flush \
+       tools/metadata/test_ust \
+       tools/relayd-grouping/test_ust
+
+if IS_LINUX
+TESTS += \
+       ust/namespaces/test_ns_contexts \
+       ust/namespaces/test_ns_contexts_change
+endif # IS_LINUX
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.023638 seconds and 4 git commands to generate.