Tests: remove duplicate notification multi-app test
[lttng-tools.git] / tests / regression / Makefile.am
index cbac90da792f43a17ad1e8d5ed6fbb9792004ebb..817918f68e66c29acd3e0a4c44ad40ec6000f5e0 100644 (file)
@@ -27,8 +27,14 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/crash/test_crash \
        tools/regen-metadata/test_ust \
        tools/regen-statedump/test_ust \
-       tools/notification/test_notification_ust \
-       tools/notification/test_notification_kernel \
+       tools/notification/test_notification_ust_error \
+       tools/notification/test_notification_ust_buffer_usage \
+       tools/notification/test_notification_ust_event_rule_condition_exclusion \
+       tools/notification/test_notification_kernel_error \
+       tools/notification/test_notification_kernel_buffer_usage \
+       tools/notification/test_notification_kernel_instrumentation \
+       tools/notification/test_notification_kernel_syscall \
+       tools/notification/test_notification_kernel_userspace_probe \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
@@ -36,10 +42,13 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/rotation/test_schedule_api \
        tools/metadata/test_kernel \
        tools/working-directory/test_relayd_working_directory \
-       tools/notification/test_notification_multi_app \
        tools/clear/test_ust \
        tools/clear/test_kernel \
-       tools/tracker/test_event_tracker
+       tools/tracker/test_event_tracker \
+       tools/trigger/start-stop/test_start_stop \
+       tools/trigger/test_add_trigger_cli \
+       tools/trigger/test_list_triggers_cli \
+       tools/trigger/test_remove_trigger_cli
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -59,10 +68,14 @@ TESTS += ust/before-after/test_before_after \
        ust/blocking/test_blocking \
        ust/multi-lib/test_multi_lib \
        ust/rotation-destroy-flush/test_rotation_destroy_flush \
-       ust/namespaces/test_ns_contexts \
-       ust/namespaces/test_ns_contexts_change \
        tools/metadata/test_ust \
        tools/relayd-grouping/test_ust
+
+if IS_LINUX
+TESTS += \
+       ust/namespaces/test_ns_contexts \
+       ust/namespaces/test_ns_contexts_change
+endif # IS_LINUX
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.022923 seconds and 4 git commands to generate.