lttng: Add remove-trigger command
[lttng-tools.git] / tests / regression / Makefile.am
index 7752404056e322cd97ec2f9c899956d8f4199f69..2ec92262ce11b7d911f341f149659fe5054aec46 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS = tools kernel ust
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
@@ -31,7 +33,16 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
        tools/rotation/test_save_load_mi \
-       tools/rotation/test_schedule_api
+       tools/rotation/test_schedule_api \
+       tools/metadata/test_kernel \
+       tools/working-directory/test_relayd_working_directory \
+       tools/notification/test_notification_multi_app \
+       tools/clear/test_ust \
+       tools/clear/test_kernel \
+       tools/tracker/test_event_tracker \
+       tools/trigger/test_add_trigger_cli \
+       tools/trigger/test_list_triggers_cli \
+       tools/trigger/test_remove_trigger_cli
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -50,7 +61,15 @@ TESTS += ust/before-after/test_before_after \
        ust/test_event_perf \
        ust/blocking/test_blocking \
        ust/multi-lib/test_multi_lib \
-       ust/rotation-destroy-flush/test_rotation_destroy_flush
+       ust/rotation-destroy-flush/test_rotation_destroy_flush \
+       tools/metadata/test_ust \
+       tools/relayd-grouping/test_ust
+
+if IS_LINUX
+TESTS += \
+       ust/namespaces/test_ns_contexts \
+       ust/namespaces/test_ns_contexts_change
+endif # IS_LINUX
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.023026 seconds and 4 git commands to generate.