Basic hashtable support for UST
[lttng-tools.git] / tests / Makefile.am
index 5ed904b477b59345c7a7833c5abe93017c57820d..e0b3697308e7e844f9defc39c2b6355c7a801a78 100644 (file)
@@ -1,5 +1,5 @@
 AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
-                 -I$(top_srcdir)/liblttngctl -g -Wall
+                 -I$(top_srcdir)/liblttngctl -g -Wall -lurcu -lurcu-cds
 
 EXTRA_DIST = runall.sh lttng/runall.sh lttng/run-kernel-tests.sh
 
@@ -7,7 +7,8 @@ noinst_PROGRAMS = test_sessions test_kernel_data_trace kernel_all_events_basic \
                                  kernel_event_basic
 
 UTILS=utils.h
-SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
+SESSIONS=$(top_srcdir)/ltt-sessiond/session.c $(top_srcdir)/ltt-sessiond/hashtable.c \
+                $(top_srcdir)/hashtable/rculfhash.c $(top_srcdir)/hashtable/hash.c
 KERN_DATA_TRACE=$(top_srcdir)/ltt-sessiond/trace-kernel.c
 LIBLTTNG=$(top_srcdir)/liblttngctl/lttngctl.c \
                 $(top_srcdir)/liblttng-sessiond-comm/lttng-sessiond-comm.c
This page took 0.022807 seconds and 4 git commands to generate.