Drop installcheck target
[lttng-tools.git] / tests / Makefile.am
index 99c20422e0cfbfca5231d3bd1046420f8e3c3fca..c7d4cd03a32f996106d09891ee0103f4d51c12b0 100644 (file)
@@ -1,25 +1,15 @@
 SUBDIRS =
-DIST_SUBDIRS = utils regression unit stress
+DIST_SUBDIRS = utils regression unit stress destructive
 
 if BUILD_TESTS
-SUBDIRS += utils regression unit stress
-endif
-
-installcheck-am:
-if BUILD_TESTS
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if PYTHON_BINDING
-       ./run.sh with_bindings_regression
-endif
-else
-       @echo "========================================="
-       @echo "WARNING: Tests were disabled at configure"
-       @echo "========================================="
+SUBDIRS += utils regression unit stress destructive
 endif
 
 check-am:
 if BUILD_TESTS
+if HAS_PGREP
+       ./utils/warn_lttng_processes.sh $(PGREP)
+endif
        ./run.sh unit_tests
        ./run.sh fast_regression
 if PYTHON_BINDING
@@ -31,8 +21,8 @@ else
        @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression root_destructive_tests
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README root_destructive_tests
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.02361 seconds and 4 git commands to generate.