Drop installcheck target
[lttng-tools.git] / tests / Makefile.am
index 27570566b509c093d542ff266710aa5beae4d848..c7d4cd03a32f996106d09891ee0103f4d51c12b0 100644 (file)
@@ -1,13 +1,39 @@
-SUBDIRS = . tools kernel
+SUBDIRS =
+DIST_SUBDIRS = utils regression unit stress destructive
 
-AM_CFLAGS = -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
+if BUILD_TESTS
+SUBDIRS += utils regression unit stress destructive
+endif
 
-EXTRA_DIST = run-report.py test_list.py utils.sh utils.h
+check-am:
+if BUILD_TESTS
+if HAS_PGREP
+       ./utils/warn_lttng_processes.sh $(PGREP)
+endif
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+if PYTHON_BINDING
+       ./run.sh with_bindings_regression
+endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
 
-if HAVE_LIBLTTNG_UST_CTL
-SUBDIRS += ust
-endif # HAVE_LIBLTTNG_UST_CTL
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression root_destructive_tests
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README root_destructive_tests
 
-check-am:
-       ./runall.sh
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023282 seconds and 4 git commands to generate.