Introduce a new utils_resolve_relative function
[lttng-tools.git] / tests / Makefile.am
index 27570566b509c093d542ff266710aa5beae4d848..c14e733a3207f97f1851ae60e874c82457e36971 100644 (file)
@@ -1,13 +1,32 @@
-SUBDIRS = . tools kernel
+SUBDIRS = utils regression unit stress
 
-AM_CFLAGS = -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
+installcheck-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+if USE_PYTHON
+       ./run.sh with_bindings_regression
+endif
 
-EXTRA_DIST = run-report.py test_list.py utils.sh utils.h
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+if USE_PYTHON
+       ./run.sh with_bindings_regression
+endif
 
-if HAVE_LIBLTTNG_UST_CTL
-SUBDIRS += ust
-endif # HAVE_LIBLTTNG_UST_CTL
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
 
-check-am:
-       ./runall.sh
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.022738 seconds and 4 git commands to generate.