Change the UST event hash table match function
[lttng-tools.git] / tests / Makefile.am
index 22d784fbaa0873f9ce03827303ba551e597fa95e..bc0f0a59afc336ffb905b37c43f90309758d01d2 100644 (file)
@@ -1,15 +1,13 @@
-AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
-                 -I$(top_srcdir)/liblttngctl -g -Wall
+SUBDIRS = . tools kernel
 
-noinst_PROGRAMS = test_sessions test_kernel_data_trace
+AM_CFLAGS = -g -Wall
+AM_LDFLAGS = -lurcu -lurcu-cds
 
-UTILS=utils.h
-SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
-KERN_DATA_TRACE=$(top_srcdir)/ltt-sessiond/trace.c
+EXTRA_DIST = run-report.py test_list.py utils.sh utils.h runall.sh
 
-test_sessions_SOURCES = test_sessions.c $(UTILS) $(SESSIONS)
-
-test_kernel_data_trace_SOURCES = test_kernel_data_trace.c $(UTILS) $(KERN_DATA_TRACE)
+if HAVE_LIBLTTNG_UST_CTL
+SUBDIRS += ust
+endif # HAVE_LIBLTTNG_UST_CTL
 
 check-am:
        ./runall.sh
This page took 0.022739 seconds and 4 git commands to generate.