Tests: fix health tests to use custom socket timeout
[lttng-tools.git] / tests / Makefile.am
index bc0f0a59afc336ffb905b37c43f90309758d01d2..9d4e0dc0d809fd00ea99085fcc565549a7c40c37 100644 (file)
@@ -1,13 +1,29 @@
-SUBDIRS = . tools kernel
+SUBDIRS = utils regression unit stress
 
-AM_CFLAGS = -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
+if USE_PYTHON
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+       ./run.sh with_bindings_regression
+else
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+endif
 
-EXTRA_DIST = run-report.py test_list.py utils.sh utils.h runall.sh
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
 
-if HAVE_LIBLTTNG_UST_CTL
-SUBDIRS += ust
-endif # HAVE_LIBLTTNG_UST_CTL
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-check-am:
-       ./runall.sh
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023536 seconds and 4 git commands to generate.