Tests: fix health tests to use custom socket timeout
[lttng-tools.git] / tests / Makefile.am
index 5feaca2d3003e6430885a689de44bd69a8b58ba9..9d4e0dc0d809fd00ea99085fcc565549a7c40c37 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = utils regression unit
+SUBDIRS = utils regression unit stress
 
 if USE_PYTHON
 check-am:
@@ -10,3 +10,20 @@ check-am:
        ./run.sh unit_tests
        ./run.sh fast_regression
 endif
+
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.022705 seconds and 4 git commands to generate.