Tests: fix health tests to use custom socket timeout
[lttng-tools.git] / tests / Makefile.am
index 4824e2215f4dbc77b1c6c41c5a09f4097fb6c3bb..9d4e0dc0d809fd00ea99085fcc565549a7c40c37 100644 (file)
@@ -1,3 +1,29 @@
-SUBDIRS = .
+SUBDIRS = utils regression unit stress
 
-dist_noinst_SCRIPTS = runall
+if USE_PYTHON
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+       ./run.sh with_bindings_regression
+else
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+endif
+
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023182 seconds and 4 git commands to generate.