Tests: fix health tests to use custom socket timeout
[lttng-tools.git] / tests / Makefile.am
index 29b8ba4f925d8d519dcff407e9f2acd33b521fa1..9d4e0dc0d809fd00ea99085fcc565549a7c40c37 100644 (file)
@@ -1,14 +1,29 @@
-AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
-                 -I$(top_srcdir)/liblttngctl -g -Wall
+SUBDIRS = utils regression unit stress
 
-noinst_PROGRAMS = test_sessions test_kernel_data_trace
-
-SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
-KERN_DATA_TRACE=$(top_srcdir)/ltt-sessiond/trace.c
+if USE_PYTHON
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+       ./run.sh with_bindings_regression
+else
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+endif
 
-test_sessions_SOURCES = test_sessions.c $(SESSIONS)
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
 
-test_kernel_data_trace_SOURCES = test_kernel_data_trace.c $(KERN_DATA_TRACE)
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-check-am:
-       ./runall.sh
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023216 seconds and 4 git commands to generate.