sessiond: Implement kernel event notifier error counter
[lttng-tools.git] / tests / Makefile.am
index c7d4cd03a32f996106d09891ee0103f4d51c12b0..8f5c15d34984eacea5519940a437de93544a628b 100644 (file)
@@ -1,19 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS =
-DIST_SUBDIRS = utils regression unit stress destructive
+DIST_SUBDIRS = utils unit regression stress destructive perf
 
 if BUILD_TESTS
-SUBDIRS += utils regression unit stress destructive
-endif
-
+SUBDIRS += . utils unit regression stress destructive perf
+if HAVE_PGREP
 check-am:
-if BUILD_TESTS
-if HAS_PGREP
-       ./utils/warn_lttng_processes.sh $(PGREP)
-endif
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if PYTHON_BINDING
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_processes.sh $(PGREP)
 endif
 else
        @echo "========================================="
@@ -21,8 +15,9 @@ else
        @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression root_destructive_tests
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README root_destructive_tests
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests perf_regression
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests perf_regression
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.022922 seconds and 4 git commands to generate.