Add tracing session test
[lttng-tools.git] / tests / Makefile.am
index e1c39bd3dc3c87d7dfc921fbdf6bb58339cf2b0f..761586e4c6bf18d81d28c463c1db666973f6ca00 100644 (file)
@@ -1,3 +1,11 @@
-SUBDIRS = . ltt-sessiond
+AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
+                 -I$(top_srcdir)/liblttngctl -g -Wall
 
-dist_noinst_SCRIPTS = runall.sh
+noinst_PROGRAMS = test_sessions
+
+SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
+
+test_sessions_SOURCES = test_sessions.c $(SESSIONS)
+
+check-am:
+       ./runall.sh
This page took 0.023432 seconds and 4 git commands to generate.