Add tracing session test
[lttng-tools.git] / tests / Makefile.am
index 76ed2b545dfe04decc58e919ffc60835c22b1087..761586e4c6bf18d81d28c463c1db666973f6ca00 100644 (file)
@@ -1,3 +1,11 @@
-SUBDIRS = .
+AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
+                 -I$(top_srcdir)/liblttngctl -g -Wall
 
-dist_noinst_SCRIPTS = runall.sh
+noinst_PROGRAMS = test_sessions
+
+SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
+
+test_sessions_SOURCES = test_sessions.c $(SESSIONS)
+
+check-am:
+       ./runall.sh
This page took 0.022797 seconds and 4 git commands to generate.