Fix: tests: provide channel name when a non-default channel exists
[lttng-tools.git] / tests / Makefile.am
index 761586e4c6bf18d81d28c463c1db666973f6ca00..6d5b00d9a6da78fc196a4a01f6abc461b8f5219a 100644 (file)
@@ -1,11 +1,15 @@
-AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
-                 -I$(top_srcdir)/liblttngctl -g -Wall
-
-noinst_PROGRAMS = test_sessions
-
-SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
-
-test_sessions_SOURCES = test_sessions.c $(SESSIONS)
+SUBDIRS = utils regression unit stress
 
+if USE_PYTHON
 check-am:
-       ./runall.sh
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+       ./run.sh with_bindings_regression
+else
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+endif
+
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
This page took 0.023322 seconds and 4 git commands to generate.