Tests: Replace prove by autotools tap runner
[lttng-tools.git] / tests / Makefile.am
index c8a85e06d5487c70481e16dd0c2bb1e795c4c933..58caeb1590fde8fdd33feb4e658b4f1f182d1bc5 100644 (file)
@@ -1,15 +1,32 @@
-SUBDIRS = utils regression unit
+SUBDIRS =
+DIST_SUBDIRS = utils regression unit stress destructive
 
-if USE_PYTHON
+if BUILD_TESTS
+SUBDIRS += . utils regression unit stress destructive
+if HAS_PGREP
 check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_lttng_processes.sh $(PGREP)
+endif
 else
-check-am:
-       ./run.sh unit_tests
-       ./run.sh fast_regression
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023824 seconds and 4 git commands to generate.