Tests: Replace prove by autotools tap runner
[lttng-tools.git] / tests / Makefile.am
index 99c20422e0cfbfca5231d3bd1046420f8e3c3fca..58caeb1590fde8fdd33feb4e658b4f1f182d1bc5 100644 (file)
@@ -1,29 +1,11 @@
 SUBDIRS =
-DIST_SUBDIRS = utils regression unit stress
+DIST_SUBDIRS = utils regression unit stress destructive
 
 if BUILD_TESTS
-SUBDIRS += utils regression unit stress
-endif
-
-installcheck-am:
-if BUILD_TESTS
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if PYTHON_BINDING
-       ./run.sh with_bindings_regression
-endif
-else
-       @echo "========================================="
-       @echo "WARNING: Tests were disabled at configure"
-       @echo "========================================="
-endif
-
+SUBDIRS += . utils regression unit stress destructive
+if HAS_PGREP
 check-am:
-if BUILD_TESTS
-       ./run.sh unit_tests
-       ./run.sh fast_regression
-if PYTHON_BINDING
-       ./run.sh with_bindings_regression
+       $(top_srcdir)/tests/utils/warn_lttng_processes.sh $(PGREP)
 endif
 else
        @echo "========================================="
@@ -31,8 +13,9 @@ else
        @echo "========================================="
 endif
 
-dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
-EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.022819 seconds and 4 git commands to generate.