Tests: Replace prove by autotools tap runner
[lttng-tools.git] / tests / Makefile.am
index 76ed2b545dfe04decc58e919ffc60835c22b1087..58caeb1590fde8fdd33feb4e658b4f1f182d1bc5 100644 (file)
@@ -1,3 +1,32 @@
-SUBDIRS = .
+SUBDIRS =
+DIST_SUBDIRS = utils regression unit stress destructive
 
-dist_noinst_SCRIPTS = runall.sh
+if BUILD_TESTS
+SUBDIRS += . utils regression unit stress destructive
+if HAS_PGREP
+check-am:
+       $(top_srcdir)/tests/utils/warn_lttng_processes.sh $(PGREP)
+endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
+
+
+dist_noinst_SCRIPTS = run.sh fast_regression long_regression root_regression root_destructive_tests
+EXTRA_DIST = run.sh fast_regression long_regression root_regression README root_destructive_tests
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.02302 seconds and 4 git commands to generate.