Tests: Ust getcpu override plugin
[lttng-tools.git] / tests / Makefile.am
index 761586e4c6bf18d81d28c463c1db666973f6ca00..2f1f1c38b36d1727b7dcbd291a41e6c5a67df719 100644 (file)
@@ -1,11 +1,32 @@
-AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
-                 -I$(top_srcdir)/liblttngctl -g -Wall
+SUBDIRS = utils regression unit stress
 
-noinst_PROGRAMS = test_sessions
+installcheck-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+if USE_PYTHON
+       ./run.sh with_bindings_regression
+endif
 
-SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+if USE_PYTHON
+       ./run.sh with_bindings_regression
+endif
 
-test_sessions_SOURCES = test_sessions.c $(SESSIONS)
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README
 
-check-am:
-       ./runall.sh
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.022796 seconds and 4 git commands to generate.