Optional test for the metadata regeneration
[lttng-tools.git] / tests / Makefile.am
index 76ed2b545dfe04decc58e919ffc60835c22b1087..017163f51d24573a46ab7b12a19ed090fd825b2e 100644 (file)
@@ -1,3 +1,55 @@
-SUBDIRS = .
+SUBDIRS =
+DIST_SUBDIRS = utils regression unit stress destructive
 
-dist_noinst_SCRIPTS = runall.sh
+if BUILD_TESTS
+SUBDIRS += utils regression unit stress destructive
+endif
+
+installcheck-am:
+if BUILD_TESTS
+if HAS_PGREP
+       ./utils/warn_lttng_processes.sh $(PGREP)
+endif
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+if PYTHON_BINDING
+       ./run.sh with_bindings_regression
+endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
+
+check-am:
+if BUILD_TESTS
+if HAS_PGREP
+       ./utils/warn_lttng_processes.sh $(PGREP)
+endif
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+if PYTHON_BINDING
+       ./run.sh with_bindings_regression
+endif
+else
+       @echo "========================================="
+       @echo "WARNING: Tests were disabled at configure"
+       @echo "========================================="
+endif
+
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression root_destructive_tests
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression README root_destructive_tests
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023474 seconds and 4 git commands to generate.