Cleanup: simplify 'poll' wrapper build
[lttng-tools.git] / src / common / compat / Makefile.am
index 82c74eedf21e371fdd212c4551dad96008570f7a..299a956b99883bd631afb63ed256711f4374a3e3 100644 (file)
@@ -1,12 +1,8 @@
-noinst_LTLIBRARIES = libcompat.la
+# SPDX-License-Identifier: GPL-2.0-only
 
-if COMPAT_EPOLL
-COMPAT=compat-epoll.c
-else
-COMPAT=compat-poll.c
-endif
+noinst_LTLIBRARIES = libcompat.la
 
-libcompat_la_SOURCES = poll.h fcntl.h endian.h mman.h dirent.h \
-               socket.h compat-fcntl.c uuid.h uuid.c tid.h \
-               getenv.h string.h prctl.h paths.h netdb.h $(COMPAT) \
-               time.h
+libcompat_la_SOURCES = poll.c poll.h fcntl.h endian.h mman.h dirent.h \
+               socket.h compat-fcntl.c tid.h \
+               getenv.h string.h paths.h pthread.h netdb.h \
+               time.h directory-handle.h directory-handle.c path.h
This page took 0.02384 seconds and 4 git commands to generate.