Cleanup: simplify 'poll' wrapper build
[lttng-tools.git] / src / common / compat / Makefile.am
index 7cd3f91fc6f8530356cc860f79d88819cd97d880..299a956b99883bd631afb63ed256711f4374a3e3 100644 (file)
@@ -1,13 +1,8 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+# SPDX-License-Identifier: GPL-2.0-only
 
 noinst_LTLIBRARIES = libcompat.la
 
-if COMPAT_EPOLL
-COMPAT=compat-epoll.c
-else
-COMPAT=compat-poll.c
-endif
-
-libcompat_la_SOURCES = poll.h fcntl.h endian.h mman.h clone.h \
-               socket.h compat-fcntl.c uuid.h tid.h \
-               getenv.h string.h $(COMPAT)
+libcompat_la_SOURCES = poll.c poll.h fcntl.h endian.h mman.h dirent.h \
+               socket.h compat-fcntl.c tid.h \
+               getenv.h string.h paths.h pthread.h netdb.h \
+               time.h directory-handle.h directory-handle.c path.h
This page took 0.023185 seconds and 4 git commands to generate.