Add lttng_waiter utils
[lttng-tools.git] / src / common / Makefile.am
index e63ddeb73668f7a3cb6bb26a25e9d372b5b1ce36..bdba28f19f2fadcc851babfa11ef950a2d3ae518 100644 (file)
@@ -2,12 +2,13 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS =
+SUBDIRS = string-utils
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
 DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
-         kernel-consumer ust-consumer testpoint index config consumer
+         kernel-consumer ust-consumer testpoint index config consumer \
+         string-utils
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
@@ -61,7 +62,7 @@ AM_CFLAGS = -fno-strict-aliasing
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                align.h bitfield.h bug.h
+                                align.h bitfield.h bug.h time.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
@@ -73,7 +74,12 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
                        unix.c unix.h \
-                       filter.c filter.h context.c context.h
+                       filter.c filter.h context.c context.h \
+                       action.c notify.c condition.c buffer-usage.c \
+                       evaluation.c notification.c trigger.c endpoint.c \
+                       dynamic-buffer.h dynamic-buffer.c \
+                       buffer-view.h buffer-view.c \
+                       waiter.h waiter.c
 
 libcommon_la_LIBADD = \
                $(top_builddir)/src/common/config/libconfig.la
This page took 0.023482 seconds and 4 git commands to generate.