condition: implement event rule based condition
[lttng-tools.git] / src / common / Makefile.am
index 49e9a8fd8a478d0d691798fdeec77da3115620ea..bbddbe7ebffc03e8b41953056e0748280c2ddd3b 100644 (file)
@@ -2,7 +2,7 @@
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS = string-utils
+SUBDIRS = string-utils filter
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -20,8 +20,8 @@ DIST_SUBDIRS = \
        config \
        consumer \
        string-utils \
-       fd-tracker
-
+       fd-tracker \
+       filter
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-4.0.xsd
@@ -34,24 +34,34 @@ libcommon_la_SOURCES = \
        actions/snapshot-session.c \
        actions/start-session.c \
        actions/stop-session.c \
-       buffer-usage.c \
        buffer-view.h buffer-view.c \
        common.h \
-       condition.c \
+       conditions/buffer-usage.c \
+       conditions/condition.c \
+       conditions/event-rule.c \
+       conditions/session-consumed-size.c \
+       conditions/session-rotation.c \
        context.c context.h \
-       credentials.h \
+       credentials.c credentials.h \
        daemonize.c daemonize.h \
        defaults.c \
+       domain.c \
        dynamic-array.c dynamic-array.h \
        dynamic-buffer.c dynamic-buffer.h \
        endpoint.c \
        error.c error.h \
        evaluation.c \
        event.c \
+       event-rule/event-rule.c \
+       event-rule/kprobe.c \
+       event-rule/syscall.c \
+       event-rule/uprobe.c \
+       event-rule/tracepoint.c \
        filter.c filter.h \
        fd-handle.c fd-handle.h \
        fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
+       kernel-probe.c \
        location.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
@@ -61,9 +71,7 @@ libcommon_la_SOURCES = \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
        runas.c runas.h \
-       session-consumed-size.c \
        session-descriptor.c \
-       session-rotation.c \
        snapshot.c snapshot.h \
        spawn-viewer.c spawn-viewer.h \
        time.c \
@@ -75,6 +83,7 @@ libcommon_la_SOURCES = \
        userspace-probe.c \
        utils.c utils.h \
        uuid.c uuid.h \
+       thread.c thread.h \
        tracker.c tracker.h \
        waiter.c waiter.h
 
@@ -87,7 +96,8 @@ libcommon_la_LIBADD = \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
-       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la
+       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
+       $(top_builddir)/src/common/filter/libfilter.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
This page took 0.023648 seconds and 4 git commands to generate.