CLI: Import argpar
[lttng-tools.git] / src / common / Makefile.am
index c29ce68dd7360e49e088e573f0387d9002b4057d..8a74b728249afe4b5c22d2336a83eb8bc37906da 100644 (file)
@@ -2,7 +2,10 @@
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS = string-utils filter
+SUBDIRS = \
+       string-utils \
+       filter \
+       argpar
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -21,7 +24,9 @@ DIST_SUBDIRS = \
        consumer \
        string-utils \
        fd-tracker \
-       filter
+       filter \
+       argpar
+
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-4.0.xsd
@@ -34,14 +39,18 @@ libcommon_la_SOURCES = \
        actions/snapshot-session.c \
        actions/start-session.c \
        actions/stop-session.c \
-       buffer-usage.c \
        buffer-view.h buffer-view.c \
        common.h \
-       condition.c \
+       conditions/buffer-usage.c \
+       conditions/condition.c \
+       conditions/event-rule.c \
+       conditions/session-consumed-size.c \
+       conditions/session-rotation.c \
        context.c context.h \
        credentials.c credentials.h \
        daemonize.c daemonize.h \
        defaults.c \
+       domain.c \
        dynamic-array.c dynamic-array.h \
        dynamic-buffer.c dynamic-buffer.h \
        endpoint.c \
@@ -49,6 +58,10 @@ libcommon_la_SOURCES = \
        evaluation.c \
        event.c \
        event-rule/event-rule.c \
+       event-rule/kprobe.c \
+       event-rule/syscall.c \
+       event-rule/uprobe.c \
+       event-rule/tracepoint.c \
        filter.c filter.h \
        fd-handle.c fd-handle.h \
        fs-handle.c fs-handle.h fs-handle-internal.h \
@@ -63,9 +76,7 @@ libcommon_la_SOURCES = \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
        runas.c runas.h \
-       session-consumed-size.c \
        session-descriptor.c \
-       session-rotation.c \
        snapshot.c snapshot.h \
        spawn-viewer.c spawn-viewer.h \
        time.c \
This page took 0.024319 seconds and 4 git commands to generate.