liblttng-ctl: add facilities for lttng_snapshot_output object
[lttng-tools.git] / src / common / Makefile.am
index e7ceefe47cf8d5a1b9e0ad659103e507557cd44e..5b186ce1f1e95f7efea53a1b70a19cfd6b6b82ed 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AUTOMAKE_OPTIONS = subdir-objects
 
 SUBDIRS = string-utils
@@ -25,7 +27,11 @@ noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
-       action.c \
+       actions/action.c \
+       actions/notify.c \
+       actions/rotate-session.c \
+       actions/start-session.c \
+       actions/stop-session.c \
        buffer-usage.c \
        buffer-view.h buffer-view.c \
        common.h \
@@ -41,11 +47,11 @@ libcommon_la_SOURCES = \
        evaluation.c \
        event.c \
        filter.c filter.h \
+       fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
        location.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
-       notify.c \
        optional.h \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
@@ -53,6 +59,8 @@ libcommon_la_SOURCES = \
        session-consumed-size.c \
        session-descriptor.c \
        session-rotation.c \
+       snapshot.c snapshot.h \
+       spawn-viewer.c spawn-viewer.h \
        time.c \
        trace-chunk.c trace-chunk.h \
        trace-chunk-registry.h \
@@ -62,7 +70,7 @@ libcommon_la_SOURCES = \
        userspace-probe.c \
        utils.c utils.h \
        uuid.c uuid.h \
-       tracker.c \
+       tracker.c tracker.h \
        waiter.c waiter.h
 
 if HAVE_ELF_H
@@ -73,7 +81,8 @@ endif
 libcommon_la_LIBADD = \
        $(top_builddir)/src/common/config/libconfig.la \
        $(top_builddir)/src/common/compat/libcompat.la \
-       $(top_builddir)/src/common/hashtable/libhashtable.la
+       $(top_builddir)/src/common/hashtable/libhashtable.la \
+       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
This page took 0.023732 seconds and 4 git commands to generate.