event-rule: introduce event rule syscall
[lttng-tools.git] / src / common / Makefile.am
index 8619b5e25f31b627db462a128286ceb0a7872bd9..556c557777bfd35dc1b3a50d65cf84311c30f0ef 100644 (file)
@@ -1,13 +1,99 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+# SPDX-License-Identifier: GPL-2.0-only
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS =
+SUBDIRS = string-utils filter
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
-DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
-         kernel-consumer ust-consumer testpoint index config consumer
+DIST_SUBDIRS = \
+       compat \
+       health \
+       hashtable \
+       kernel-ctl \
+       sessiond-comm \
+       relayd \
+       kernel-consumer \
+       ust-consumer \
+       testpoint \
+       index \
+       config \
+       consumer \
+       string-utils \
+       fd-tracker \
+       filter
+# Common library
+noinst_LTLIBRARIES = libcommon.la
+EXTRA_DIST = mi-lttng-4.0.xsd
+
+libcommon_la_SOURCES = \
+       actions/action.c \
+       actions/group.c \
+       actions/notify.c \
+       actions/rotate-session.c \
+       actions/snapshot-session.c \
+       actions/start-session.c \
+       actions/stop-session.c \
+       buffer-usage.c \
+       buffer-view.h buffer-view.c \
+       common.h \
+       condition.c \
+       context.c context.h \
+       credentials.c credentials.h \
+       daemonize.c daemonize.h \
+       defaults.c \
+       dynamic-array.c dynamic-array.h \
+       dynamic-buffer.c dynamic-buffer.h \
+       endpoint.c \
+       error.c error.h \
+       evaluation.c \
+       event.c \
+       event-rule/event-rule.c \
+       event-rule/kprobe.c \
+       event-rule/syscall.c \
+       filter.c filter.h \
+       fd-handle.c fd-handle.h \
+       fs-handle.c fs-handle.h fs-handle-internal.h \
+       futex.c futex.h \
+       kernel-probe.c \
+       location.c \
+       mi-lttng.c mi-lttng.h \
+       notification.c \
+       optional.h \
+       payload.c payload.h \
+       payload-view.c payload-view.h \
+       pipe.c pipe.h \
+       readwrite.c readwrite.h \
+       runas.c runas.h \
+       session-consumed-size.c \
+       session-descriptor.c \
+       session-rotation.c \
+       snapshot.c snapshot.h \
+       spawn-viewer.c spawn-viewer.h \
+       time.c \
+       trace-chunk.c trace-chunk.h \
+       trace-chunk-registry.h \
+       trigger.c \
+       unix.c unix.h \
+       uri.c uri.h \
+       userspace-probe.c \
+       utils.c utils.h \
+       uuid.c uuid.h \
+       thread.c thread.h \
+       tracker.c tracker.h \
+       waiter.c waiter.h
+
+if HAVE_ELF_H
+libcommon_la_SOURCES += \
+       lttng-elf.c lttng-elf.h
+endif
+
+libcommon_la_LIBADD = \
+       $(top_builddir)/src/common/config/libconfig.la \
+       $(top_builddir)/src/common/compat/libcompat.la \
+       $(top_builddir)/src/common/hashtable/libhashtable.la \
+       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
+       $(top_builddir)/src/common/filter/libfilter.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
@@ -33,6 +119,10 @@ if BUILD_LIB_RELAYD
 SUBDIRS += relayd
 endif
 
+if BUILD_LIB_FD_TRACKER
+SUBDIRS += fd-tracker
+endif
+
 if BUILD_LIB_KERNEL_CONSUMER
 SUBDIRS += kernel-consumer
 endif
@@ -57,32 +147,18 @@ if BUILD_LIB_CONSUMER
 SUBDIRS += consumer
 endif
 
-AM_CFLAGS = -fno-strict-aliasing
-
-noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
-                                uri.h utils.h lttng-kernel-old.h \
-                                align.h bitfield.h bug.h time.h
-
-# Common library
-noinst_LTLIBRARIES = libcommon.la
-EXTRA_DIST = mi-lttng-3.0.xsd
-
-libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
-                       common.h futex.c futex.h uri.c uri.h defaults.c \
-                       pipe.c pipe.h readwrite.c readwrite.h \
-                       mi-lttng.h mi-lttng.c \
-                       daemonize.c daemonize.h \
-                       unix.c unix.h \
-                       filter.c filter.h context.c context.h
-
-libcommon_la_LIBADD = \
-               $(top_builddir)/src/common/config/libconfig.la
-if LTTNG_BUILD_WITH_LIBUUID
-libcommon_la_LIBADD += -luuid
-endif
-if LTTNG_BUILD_WITH_LIBC_UUID
-libcommon_la_LIBADD += -lc
-endif
+noinst_HEADERS = \
+       align.h \
+       bug.h \
+       defaults.h \
+       error.h \
+       futex.h \
+       lttng-kernel.h \
+       lttng-kernel-old.h \
+       macros.h \
+       time.h \
+       uri.h \
+       utils.h
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024329 seconds and 4 git commands to generate.