Move futex.c/.h to libcommon
[lttng-tools.git] / src / common / Makefile.am
index ba93810a8c3fe6af5bf8bd7c4188d037de4421ec..460f2a2de989bc65605f25ba67eb7102245191d4 100644 (file)
@@ -1,25 +1,14 @@
 AM_CPPFLAGS =
 
-SUBDIRS = hashtable kernel-ctl sessiond-comm kernel-consumer ust-consumer
+SUBDIRS = compat hashtable kernel-ctl sessiond-comm kernel-consumer ust-consumer
 
 AM_CFLAGS = -fno-strict-aliasing
 
-noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h
+noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h
 
 noinst_LTLIBRARIES = libcommon.la
 
-libcommon_la_SOURCES = runas.c runas.h common.h
-
-if COMPAT_EPOLL
-COMPAT=compat/compat-epoll.c
-else
-COMPAT=compat/compat-poll.c
-endif
-
-noinst_LTLIBRARIES += libcompat.la
-
-libcompat_la_SOURCES = compat/poll.h compat/fcntl.h compat/splice.h compat/endian.h \
-                       compat/socket.h compat/compat-fcntl.c $(COMPAT)
+libcommon_la_SOURCES = runas.c runas.h common.h futex.c futex.h
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
@@ -30,7 +19,7 @@ libconsumer_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-consumer/libkernel-consumer.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
-               $(top_builddir)/src/common/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la
 
 if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
This page took 0.023252 seconds and 4 git commands to generate.